Sailrite Enterprises, Inc. Homepage
Forum Home Forum Home > Sewing Machines > Sailrite Sewing Machines
  New Posts New Posts RSS Feed - Tensioner Issues
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

This forum is now a read-only site and discussions have been archived. You can still read the content but will no longer be able to post. For our ongoing how-to project blogs and video content, visit our “How-To” page at For one-on-one assistance, email us at

Forum LockedTensioner Issues

 Post Reply Post Reply
dkall View Drop Down
Forum Member
Forum Member

Joined: 10 March 2019
Location: Fiji
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote dkall Quote  Post ReplyReply Direct Link To This Post Topic: Tensioner Issues
    Posted: 10 March 2019 at 3:43pm
It appears I have two issues. First I'm near the end of a large size project in Fiji, sewing Textiline and Sunbrella on one of my last runs I began to get major looping on the underside. I  took scrap Sunbrella fabric and tried to adjust the tension and I could not get the looping to disappear.  I looked at the tensioner and tried tightening it all the way and tried running the V-92 thread around it twice and still I was getting some looping; but most has disappeared.  Up until I put in a new bobin of thread everything was working perfectly.  What gives?  Needles size is 18, Machine LZ-1 .

Trying to solve the earlier issues I found the wishbone thingie for releasing tension in the innards and took that off (what  a PITA). There I discovered that when lifting the foot it doesn't seem to dis engage the thread tension.  If possible could someone give me the length of the pin that does that?  I can make another I think rather easily. As i am in Fiji I am not interested in spending FedEx money for  a couple of dollar item. Thanks in advance.
Cheers, Dave
Back to Top
MattGrant View Drop Down
Admin Group
Admin Group

Sailrite Employee - Expert

Joined: 21 April 2005
Location: United States
Status: Offline
Points: 3012
Post Options Post Options   Thanks (0) Thanks(0)   Quote MattGrant Quote  Post ReplyReply Direct Link To This Post Posted: 11 March 2019 at 9:25am
Hi Dave,

What you have done with the tension is not a good idea. I think this correction is masking the real issue which is likely the bobbin threading or that the retaining ring cap spring has been struck by the needle. If so use a piece of emery paper to polish the bur. Then set your thread tension back to normal and test again.

The thread tension post will not be causing this issue and they do not fail. But it could be that the core for the tension assembly is not set at the correct in/out position. This would only impact how easily the thread releases with the presser foot up. To set it remove the left end cover of the machine and find the set screw to the left of the tension assembly. Loosen the screw and drop the presser foot. Now adjust the setting of the core so that the release post has a gap of about 1/32" from the connecting actuator paddle. Tighten the screw and now when you lift the presser foot the tension plates will open to allow the thread to pull through.

If this is not enough to help please open a support case using this link:

Best Regards, Matt Grant
Best Regards,
Matt Grant
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down