Sailrite Enterprises, Inc. Homepage
Forum Home Forum Home > Sewing Machines > Sailrite Sewing Machines
  New Posts New Posts RSS Feed - Posi-pin and Monster Balance wheel question
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Posi-pin and Monster Balance wheel question

 Post Reply Post Reply
Author
Message
Elbarcolutra View Drop Down
Forum Member
Forum Member


Joined: 07 December 2013
Location: Seattle
Status: Offline
Points: 16
Post Options Post Options   Thanks (0) Thanks(0)   Quote Elbarcolutra Quote  Post ReplyReply Direct Link To This Post Topic: Posi-pin and Monster Balance wheel question
    Posted: 01 October 2017 at 10:18pm
Hi--
I just tried my Monster Balance wheel for the first time.  For some reason, I can't get the posi-pin to slide into a hole.  I reattached the plastic wheel, and the posi-pin fits into all of the holes.  I did this about 5 times--each time, the Monster Balance wheel will not let me put the posi-pin in, and the plastic wheel works fine.  Any suggestions about how to troubleshoot?  I'm hesitant to use force, as the posi-pin is easy to insert with the plastic wheel.
Thanks
Back to Top
MattGrant View Drop Down
Admin Group
Admin Group

Sailrite Employee - Expert

Joined: 21 April 2005
Location: United States
Status: Offline
Points: 2802
Post Options Post Options   Thanks (0) Thanks(0)   Quote MattGrant Quote  Post ReplyReply Direct Link To This Post Posted: 02 October 2017 at 8:03am
Please call in to 800-348-2769 and start a support case for the Monster wheel. This sounds like a defective wheel. Please let the operator know that Matt Grant suggested the wheel needs to be replaced. Sorry about the trouble.
Best Regards,
Matt Grant
Sailrite
Back to Top
Elbarcolutra View Drop Down
Forum Member
Forum Member


Joined: 07 December 2013
Location: Seattle
Status: Offline
Points: 16
Post Options Post Options   Thanks (0) Thanks(0)   Quote Elbarcolutra Quote  Post ReplyReply Direct Link To This Post Posted: 03 October 2017 at 12:12am
I did a little more investigation.  When the wheels are off the sewing machine, I can get the posi-pin into the hole (and out the other side) on the plastic wheel, but not on the metal one.  I assume that confirms that the wheel is the problem, correct?  Do I need to put a lot of pressure on the posi-pin before it goes through the Monster Wheel when it is off the sewing machine?

Note:  I actually did get the pin into the wheel once this morning, but now can't do it again (but assume if I keep trying, I might eventually get it to go in again).  
Back to Top
MattGrant View Drop Down
Admin Group
Admin Group

Sailrite Employee - Expert

Joined: 21 April 2005
Location: United States
Status: Offline
Points: 2802
Post Options Post Options   Thanks (0) Thanks(0)   Quote MattGrant Quote  Post ReplyReply Direct Link To This Post Posted: 03 October 2017 at 10:02am
You need a replacement wheel. The one you have must have the hole misdrilled. Please call in and ask for Lisa.
Best Regards,
Matt Grant
Sailrite
Back to Top
Elbarcolutra View Drop Down
Forum Member
Forum Member


Joined: 07 December 2013
Location: Seattle
Status: Offline
Points: 16
Post Options Post Options   Thanks (0) Thanks(0)   Quote Elbarcolutra Quote  Post ReplyReply Direct Link To This Post Posted: 07 October 2017 at 11:52am
Thanks for the help.  After a few emails with customer service, and with a little sleuthing with help from the superb Sailrite staff, we were able to determine that it wasn't a wheel problem at all, but a problem with the spring of the posipin getting stretched out and thus sitting in a groove that blocked the pin from going through the wheel.  The wheel is fine, and my workaround is to hold the spring away from the groove.

As always, I'm very impressed with the Sailrite focus on customer service--second to none!
Back to Top
MattGrant View Drop Down
Admin Group
Admin Group

Sailrite Employee - Expert

Joined: 21 April 2005
Location: United States
Status: Offline
Points: 2802
Post Options Post Options   Thanks (0) Thanks(0)   Quote MattGrant Quote  Post ReplyReply Direct Link To This Post Posted: 07 October 2017 at 9:31pm
That would certainly cause the issue. Thanks so much for working with the Sailrite team to figure it out.
Best Regards,
Matt Grant
Sailrite
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down